Could not load file or assembly Microsoft.SharePoint.Taxonomy

Apr 29, 2014 at 11:43 AM
I'm trying to export metadata from Sharepoint 2013 (or is that not supported?). As there is no installer, I'm not sure where to run the tool from, so I try at my downloads folder. Yes, I'm admin to Sharepoint as well as local admin to the server. After filling the fields, I push the export button and get an error saying:

System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.SharePoint.Taxonomy, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c' or one of its dependencies. The system cannot find the file specified.
File name: 'Microsoft.SharePoint.Taxonomy, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c'
at BulkCSVImporter.Form1.GetTaxonomyHandle()
at BulkCSVImporter.Form1.btnExport_Click(Object sender, EventArgs e)
at System.Windows.Forms.Control.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ButtonBase.WndProc(Message& m)
at System.Windows.Forms.Button.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
Coordinator
May 29, 2014 at 6:08 AM
You are correct, this needs to be re-compiled for 2013.